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JournalViewer 

A desktop application for viewing and interrogating ISIS instrument journal files 

 

Tristan G. A. Youngs 

ISIS Facility, STFC Rutherford Appleton Laboratory 

Harwell Campus, Didcot, Oxfordshire, OX11 0RT 

 

Abstract 

JournalViewer is a graphical desktop application which allows run data for any ISIS instrument 

to be easily viewed and interrogated, by parsing the relevant XML data available on the local 

network. It provides at-a-glance information on the title, timing, and user information 

associated to each run, which can be sorted, grouped by RB number or user ownership, and 

filtered according to several criteria. Moreover, JournalViewer also parses sample environment 

data contained with the log or nxs files associated with each run, and allows any logged value to 

be plotted as a function of time. JournalViewer can also work on ‘offline’ data stored in local 

directories, extracting run information in order to (re)create a bespoke journal file, permitting 

users to make use of the program at their home institutions. 
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1. Introduction 

The availability of basic run information collected on a given ISIS instrument is  a basic 

requirement for an operational beamline. Metadata for each individual run is captured 

automatically by the underlying system and stored in ‘journal’ files – XML-formatted files which 

are local to each instrument. The data contained therein is viewable through the “Journal 

Viewer” page within the Sample Environment Control Interface (SECI), providing information 

such as run number, run title, and user information. The subject of this technical report, 

JournalViewer, is a standalone desktop application designed for use outside of SECI, and which 

aims to provide better access to the information contained within the instrument journal files, 

adding additional functionality such as sorting, grouping and filtering of this data. Beyond this, it 

also allows interrogation of the run data itself, along with the associated log file containing 

instrument and sample environment data block values captured within SECI, and provides 

graphing capabilities for this data. 

 

2. Code Overview 

JournalViewer is written entirely in C++, and uses the Qt toolkit for user interface and network 

access functionality. Reading of instrument raw files is performed through use of libget by F. 

Akeroyd, which is encapsulated in a C++ wrapper for ease of use throughout the code. Reading 

of nxs files is achieved through the HDF5 library, again using a custom C++ wrapper to provide 

easy insertion within the code. The source code is not publicly-available, but installers are 

available for Windows, OSX, and some Linux variants. 

 

3. Operation 

While local to each ‘NDH’ instrument computer, the journal files for every beamline are also 

mirrored to a network filestore location (http://data.isis.rl.ac.uk/journals). It is these files that 

JournalViewer reads from the network, parses, and displays, as its primary function. This means 

that, while on the local network (potentially via VPN) every stored journal file for every 

beamline is available within JournalViewer from any computer. Moreover, if the location of the 

ISIS data archive is set, JournalViewer will also be able to plot block value data from any run file 

detailed within the journal. The journal files accessed can optionally be saved to a specified local 

directory, meaning basic run information can be viewed even when off-site (without VPN) or 

offline.  JournalViewer is also able to traverse through directories of run data (i.e. raw, log, 

and/or nxs files) stored on a local machine, permitting block value interrogation to be 

performed offline as well. This is of particular use to external users who wish to use the 

software to process / view the run data associated with their experiments, and a cut-down 

version of the software exists for distribution outside of ISIS.   This version removes any ability 

to access journals via the network, and only allows selection / interrogation of local data stored 

on the user’s machine. Otherwise the functionality remains the same 

http://data.isis.rl.ac.uk/journals


4. Main Interface 

The main window displays the contents of the current instrument / journal target, and allows 

filtering of this data through controls located at the top of the main table (Figure 1). A single 

journal file or, optionally, the complete history of all available journal files available for a single 

instrument can be selected and viewed with the Instrument and Cycle controls (1).  If local 

data is also present then this is accessible via the Instrument list through the ‘LOCAL’ entry. In 

this case the Cycle control will display all individual groups of local data that are available. 

 

Figure 1 – JournalViewer’s main window 

4.1. Main View 

The main view (2) displays in tabular form the available run data in the current journal. Run 

data are, by default, listed in order of increasing run number, but the quantity by which visible 

data are sorted can be changed by clicking on the header for the relevant column.  The visible 

columns can be adjusted through the View menu. The visibility and ordering of columns in the 

main view also affects the format of the output from the CLI interface (see Chapter 8). 

4.2. Filtering 

The Filter group (3) at the top of the main window allows limits on the visible run data for the 

current instrument/journal selection to be tailored to suit – by default all runs from the current 

journal target(s) are shown. Run data may be filtered by any combination of: a) text, wildcard, 

or regular expression (Perl style) search of the run Title; b) available User and RB No. data 

(extracted from the available runs); c) start / running time and date, and; d) run number limits.  

For the latter criteria, these limits may be made persistent across refreshes of the journal data 

by enabling the padlock icon next to the relevant quantity. 



4.3. Grouping 

Instead of sorting runs by one of the displayed quantities, runs possessing the same title may be 

listed together in continuous chunks by enabling grouping (Tools→Enable Grouping, or Ctrl-

G). Selecting the option a second time will disable grouping and revert to the previous sort 

order. This feature facilitates simplified transfer of associated measurement data into data 

reduction and processing packages. 

4.4. Item Selection 

Left-clicking an item or range of items selects them for further action. Right-clicking on a 

(selected) item brings up a context menu with additional options: 

Select Similar  Selects all runs with the same Title as the clicked item 

Sample Report  Generates a brief report on the selected items, stating total μAh 

accumulated for each unique sample name, etc. 

Copy as Gudrun File List  Copies the selected items to the clipboard as a block of formatted 

text suitable for pasting into a Sample section in a Gudrun input file.1 

Double-clicking on an item (or pressing F1) will attempt to load SECI log information from 

either the *.log file associated with the run or, if not found, the associated *.nxs file. Alternatively, 

the Selection menu allows explicit usage of either *.log or *.nxs files as the plot data source. If 

data is successfully loaded, a Run Data window is opened allowing the data to be plotted (see 

Chapter 5, Sample Environment Data Plotting). Several Run Data windows may be opened 

simultaneously by returning to the main window and selecting different (or the same) run 

entries from the table in the same manner. The Selection menu also allows the column contents 

for the current item selection to be copied as text to the clipboard. 

A quick text search of the visible run data titles can be made through Tools→Find (or pressing 

Ctrl-F), and allows the user to cycle through successive matches of the search string in both 

forward and reverse order (F3 and Shift-F3 respectively. Note that any current selection will be 

lost. 

 



5. Sample Environment Data Plotting 

The Run Data Window (Figure 2, accessed by double-clicking an entry in the main table, or by 

using options on the View menu) allows interrogation of the data contained within the log and 

Nexus files associated with each experimental run. This data essentially encompasses all block 

values defined in the current SECI session, written at frequencies defined on a per-value basis, 

and can include beamline information such as jaw settings, ISIS status variables such as the 

current being delivered to the target stations, and any values being read out from sample 

environment equipment currently installed. JournalViewer allows all this information to be 

quickly and easily plotted as a function of time, and across multiple runs. 

 

Figure 2 – The Run Data Window 

For a set of plotted data files, the SECI / Run Logs tab gives a list of those run numbers at the 

top-right (1), and a list of the available SECI block values across all those run numbers at the 

bottom-right of the window (2). By default, all runs are selected when the window is shown – 

properties of interest may then be plotted on the graph area by selecting them from the lower 

list. The selected run numbers / run data may be exported to a text file with the Export button 

at the lower-right of the window. The Single Values tab lists various parameters such as SECI 

configuration name, wiring table file etc. (note that this information is extracted only from the 

nxs file, so this table will be empty if plotting from the log file), while the Analysis tab lists each 

run property in turn, and gives the total number of available points, the global minimum and 

maximum values, and the literal average of those values for each run. 

The main graphing area (3) on the left of the SECI / Run Logs tab displays the currently-

selected data – datasets from individual runs are drawn in different colours, while run 

properties are differentiated by different line styles (solid, dashed, etc.). Several options (4) 

affect how the data is plotted: 

Option Description 

Absolute Time If ticked (the default) then the x-axis on the graph will use date/time values as 

markers, typically giving a continuous plot of the run property as a function of 

time. If unticked then the data for each run will be plotted against hours, 

minutes and seconds relative to the starting time of each data collection period 

(i.e. when the BEGIN command was issued within SECI). As such, negative 



time indicates SECI log values that were collected before the BEGIN command. 

Begin/End Toggles display of vertical blocks defining the exact start and end times of the 

run (i.e. corresponding to when the BEGIN and END commands were issued to 

the DAE). 

Legend Toggles display of a legend listing each run property being displayed. 

On Change Controls how lines between datapoints are drawn.  If not enabled, the data is 

assumed to represent a continuously-changing variable, and draws lines 

directly between each consecutive point. However, this is not necessarily the 

case, and SECI allows datapoints to be logged only if the value has changed 

beyond a specified threshold limit. Enabling the On Change option will draw 

strict horizontal and vertical lines between points, so as not to ‘embellish’ the 

data. 

 

The main graph is fully controllable with the mouse, and several keyboard shortcuts also exist. 

The current position of the mouse in data-space coordinates is always displayed at the bottom-

right of the tab. 

Action Description 

Left-Click Shifts the viewport of the graph, without changing the scale of the x and y 

axes. The direction and magnitude of the shift is defined by the vector 

between the centrepoint of the graph and the current mouse position. 

Left-Click-Drag Allows a portion of the graph to be zoomed in to, as defined by the 

rectangle drawn by the mouse. 

Middle-Click-Drag Slides the visible area of the graph with the mouse. 

Right-Click Raises a context menu with several options. Show All resets the x and y 

axes to display all of the data for the currently-selected runs / properties. 

Copy to Clipboard places an image of the current graph (at its current 

size) on the clipboard for quick pasting elsewhere. 

 

The available keyboard shortcuts are as follows: 

Key Description 

A Expand the limits of the graph on X and Y to encompass all of the data 

currently being displayed. 

K Toggle between logarithmic and normal x axis 

L Toggle between logarithmic and normal y axis 

  



6. Generating Quick Reports 

Selecting Tools→Create Quick Report opens up a window displaying various information 

collected for each distinct RB number present (used) in the currently loaded journal(s), Figure 

3. For each RB number, the total proton time used, total proton current collected, number of 

runs made etc. is given.  Since there is no guarantee that all runs for a given experiment will be 

performed back-to-back, JournalViewer tries to take account of this by partitioning the runs into 

‘parts’, reflecting the contiguous chunks of data accumulation under a single RB number 

performed on the instrument. Thus, the total proton time is a reasonable reflection of 

accelerator time ‘spent’ on an experiment, while the literal time gives a straight measure of time 

elapsed between the start of the first run and end of the last run. 

 

Figure 3  – The Quick Report window, summarising each RB number in the current journal(s) 



7. Generating Experiment Reports 

A more comprehensive report for a single RB number can be generated in a so-called 

experiment report, accessed through Tools→Create Experiment Report.  The experiment 

report window then offers several options guiding the content of the resulting report, the main 

body of which contains the details of every run collected during that experiment. 

7.1. Experiment  

A single RB number must first be selected on the Experiment tab, Figure 4, and which will be 

the target of the report. The list of available RB numbers (1) is taken from the current 

journal(s). The User string is taken from the first run number from the experiment, but may be 

edited here (e.g. to put full names of experimenters in etc.) (2). Optionally, the experiment 

report may be ‘tagged’ to state that this is one part of a multi-part experiment using the Part 

controls. Note that ‘parts’ in this context are distinct from those determined in a quick report. 

 

Figure 4 – Selection of a target RB number in the Experiment Report window 

 

Figure 5 – Selection of beamline parameters to be included in an experimental report 

7.2. Instrument Information 

It is often useful to store beamline-related information along with the experiment, and the 

Instrument Information tab, Figure 5, allows single block values taken from a specified run in the 



experiment or, optionally, the Current SECI Values, (1) to be added to the header of the report. 

Any item checked in the list (2) will appear in the header of the final report. 

7.3. Run Data 

In much the same way as the visible columns of the main table may be changed, so the 

properties for each run to be output may be modified on the Run Data tab. The left list 

represents the available properties, while the right list shows those that are currently selected 

for output in the final report.  Selecting one and clicking the appropriate left / right arrow will 

move the properties between the two lists, and the final ordering of the displayed properties 

can be changed with the up / down arrows. 

 

Figure 6 – Output parameter selection for the individual run data to be placed in an experimental report 

 

Figure 7 – Optional analysis graphs to be output at the start of the experimental report 

7.4. Analysis 

Finally, the report may be enhanced with time analysis of the runs taken in the experiment (1) 

and graphs of the primary ISIS parameters (beam current and moderator temperatures) over 

the course of the experiment (2,3), Figure 7. These graphs, if selected, will appear at the start of 

the report. Optionally, warning marks may be printed on the graphs where the parameters go 

outside of a specified range (designed to be related to the vetoes present on the instrument used 

to collect the data) by selecting the relevant Warn checkboxes. As with the Run Data window 



(Chapter 5) these parameters are plotted as if they were continuously changing variables, but 

may be plotted in the alternative discrete style by selecting the OC? (‘on change’) checkboxes. 



8. Command-Line Interface 

Occasionally it is useful to perform a quick search of journal data without loading the user 

interface, and for this purpose JournalViewer has a basic command-line interface.  Run without 

any command-line arguments, JournalViewer will always start up with the GUI. Available 

command-line options are: 

Option Description 

–a List all run data for the current journal 

–c columns Set the run property columns to display for search output. If the 

option is omitted the current columns visible in the main GUI table are 

used. Otherwise, a string of characters representing the required 

columns can be given, selected from the following: 

a Accumulated current in μAmps 

b RB number 

c Cycle 

d Duration of run 

e End date/time of run 

m Accumulated Mevents 

r Run number 

s Start date/time of run 

t Title of run 

u User 

–h Display help for all available command-line options (i.e. the contents 

of this table) 

–i instrument Change target instrument to that provided. Long (e.g. SANDALS) or 

short (e.g. SLS) names may be provided.  If the option is omitted the 

default instrument is used. 

–j cycle Change target journal to the ISIS operating cycle provided. Note that 

only the YY/N part should be given (e.g. ‘15/4’). The string ‘All’ is also 

accepted, and targets all available cycles in the subsequent search.  If 

the option is omitted the journal for the most recent cycle is used. 

–l Lists all available journals for the current instrument and exit 

–r “regular expression” Perform a regular expression search of the run titles in the current 

journal, printing those that match. 

–s “plaintext string” Perform a plain text search of the run titles in the current journal, 

printing those that match. 

–w “wildcard string” Perform a wildcard text search of the run titles in the current journal, 

printing those that match. 

–v Display version information and exit 



 

8.1. Usage Examples 

To search the current (most recent) journal for the current instrument, looking for the word 

‘Vanadium’ in the title: 

bob@pc:~>  jv –s Vanadium 

To search for any ‘Empty’ run in a cryostat (for instance): 

bob@pc:~>  jv –w "Empty*cryostat" 

For a set of sample cells labelled N1 through to N10, display all empty cell runs for the current 

instrument / journal, excluding those for N4 through to N9, using a regular expression search: 

bob@pc:~>  jv –r "Empty N[^4–9]" 

Change the current instrument to IRIS, the current cycle to 11/2, and display all runs for that 

journal: 

bob@pc:~>  jv –i IRIS –j 11/2 –a 

For the current instrument, change to cycle 09/5, and display the run number, title, start/end 

date/times, and accumulated current, for all runs in that journal: 

bob@pc:~>  jv –j 09/5 –c rtse –a  



9. Settings 

General setup and program preferences are contained in the Settings window (Tools→Settings 

or Ctrl-T). Some critical options affecting the bulk of JournalViewer’s abilities are set here, so it 

is worth checking that they are correct, especially for non-Windows systems. 

9.1. Access Settings 

The Access tab of the Settings window, Figure 8, specifies the network and disk locations of the 

target journal files, and also defines how data is accessed. 

 

Figure 8 – Access settings 

Setting Description 

Default Instrument (1) A specific instrument whose journal files should be loaded 

immediately on startup (or LOCAL for the local user data, or <None> 

to use the first instrument in the list). 

ISIS Journal Source (2) The location from which to acquire journal data for all instruments. 

Local Disk Only means only previously-saved local journals will be 

available, while Network Only reloads journal files from the 

Network Source every time. Local Disk, Updated from Net will 

check for local copies of journals first, reloading out-of-date journals 

from the network, and storing updated journals on disk as it proceeds. 

The Local Directory should be set to a location on the user’s hard 

disk, and will be used to store updated journals retrieved from the 

network. The Network Source should be set to the location of the 

journal xml files accessible by HTTP (currently 

http://data.isis.rl.ac.uk/journals/). Automatic reloading of the 

currently-displayed journal file can be enabled with the Auto Reload 

feature, with a corresponding poll interval time (in minutes). 

Data Source (3) The two locations here represent the areas to search when attempting 

to load *.log or *.nxs files (when plotting data etc.). The Data 

Directory should point to the network share location that holds all 

instrument run data. Note that this setting is heavily operating 

http://data.isis.rl.ac.uk/journals/


system-dependent. The User Data Directory may point to a disk-

based location where raw, log, and nxs files exist, and which 

JournalViewer treats as data for the LOCAL instrument. 

Block Data Source  (4) When reading block (sample environment) data for a given run there 

are two possible sources of data: the log file, or the nxs file. These 

options allow control of which source(s) to use when loading data for 

plotting (by double-clicking on the main table or using the F1 

shortcut). 

 

9.2. Export Settings 

The controls on the Export tab, Figure 9, allow tweaking of the style in which exported pdf 

documents are displayed, including setting margins.  The settings do not affect text document 

export, save for the ability to set the margins for such documents separately. 

Setting Description 

Appearance (1) Colours used for header text and background in exported tables in pdf 

documents. If Highlighting is enabled, alternate rows will use the 

specified highlight colours. Normal, non-highlighted rows are always 

written using black text on a white background. 

Font (2) Specified the particular font to use for text in exported documents, 

and for graphs in the Run Data window (Chapter 5) and in generated 

experimental reports (Chapter 7). 

Data Format (3) When exporting a list of runs from the main table, selects between a 

‘simple’ list of run data, or an ‘indented’ form. A simple list puts all 

data items for a given run on one line, while in the latter the run 

number and title are written on a ‘header’ line of their own, followed 

by additional data on the next (indented) line.  Additionally, if 

grouping of runs is enabled, runs with similar titles will appear under 

the same heading. 

Margins (4) Sets the margins, in centimetres, to use in both plain exported data 

and for experimental reports. 

 



 

Figure 9 – Export settings  

9.3. Accessing the ISIS Data Directory 

For Windows machines on the STFC network it should be sufficient to use \\isis\inst$ as the 

Data Directory, provided the current user is authenticated with a suitable federal ID. For OSX 

machines it is necessary to first mount the correct Windows share: 

1) From the Finder tool select Go→Connect to Server 

2) Enter smb://isis/inst$ as the Location 

3) Click Connect and you will be prompted for your federal ID and password 

4) Once successfully authorised the data should be accessible through 
\\Volumes\\isis$  

5) In JournalViewer, enter \\Volumes\\isis$ as the Data Directory 

For Linux systems the process is similar, but the variety present within the available 

distributions makes a comprehensive guide impossible. From the command line the procedure 

is as follows on an OpenSuSE 13.1 system: 

1) As root, create a directory mount point for the Windows share, e.g. /isisdata  

2) As root, mount the Windows share with the following command, replacing abc12345 

with your federal ID: 

bob@pc:~> mount –t cifs //isisdata/inst$ –o "user=abc12345,sec=ntlm" /isisdata 

3) Enter the password associated to your federal ID 

4) In JournalViewer, enter /isisdata as the Data Directory 

9.4. Using JournalViewer on Local Data 

As well as retrieving journal and run data from network locations (i.e. when connected to the 

STFC network as an authenticated user) JournalViewer is able to probe and manage data stored 

locally in the User Data Directory. The intended purpose of this is to allow facility users to 

make use of JournalViewer’s functionality on their collected data after having returned to their 



home institution, where no access to the original ISIS journal data is available. The layout of the 

directory should be as follows – assuming that the location is set to 

C:/Users/abc12345/MyExperimentData, then one may organise user data as follows: 

   C:/Users/abc12345/MyExperimentData 

    RB1220486/ 

    NIMROD00014136.log 

    NIMROD00014136.raw 

    NIMROD00014137.log 

    NIMROD00014137.raw 

     ... 

    RB1310475/ 

    NIMROD00018606.nxs 

    NIMROD00018606.raw 

    NIMROD00018607.nxs 

    NIMROD00018607.raw 

     ... 

   SLS41093.raw 

   SLS41094.raw 

   SLS41095.raw 

     ... 

    WaterData/ 

    NIMROD00026207.nxs 

    NIMROD00026207.raw 

    NIMROD00026208.nxs 

    NIMROD00026208.raw 

     ... 

 

The basic principle here is to store the files related to each distinct experiment in their own 

separate directories, the names of which will be displayed as individual entries in the Data 

selector (which replaces the Cycle selector when the instrument is set to LOCAL). For the 

example given above, the entries will be ‘RB1220486’, ‘RB1310475’, and ‘WaterData’. Note that 

there are also some ‘loose’ files in the root of the user directory (SLS41093.raw etc.) – any files 

found in this directory will be added to a journal entry called ‘Top’. 

Before this data is available within JournalViewer, index files must be created by selecting 

Tools→Regenerate Local Journals. JournalViewer will then search through all subfolders in 

the specified user directory, extracting the necessary information from the nxs or raw files in 

order to build journals for them. Since this operation can be quite time consuming, it is never 

run automatically – as such, if files are changed, moved, or new raw or nxs files are added, the 

index files must be updated manually by selecting Tools→Regenerate Local Journals. 

 



10. Outlook 

JournalViewer offers the ability for instrument scientists, technical staff, and facility users alike 

to easily search through journal data for any ISIS instrument over any available cycle. Sample 

environment block values may be extracted and plotted using built-in graphing capabilities, and 

exported to graphical images or raw text data. In addition, JournalViewer allows reports to be 

generated for individual RB numbers, offering facile take-home document generation for users. 

Future developments may cover the extraction and plotting of individual spectra (e.g. monitors) 

from the associated data, enhanced block value plotting capabilities (e.g. value vs. value), and 

basic data analysis routines. 
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